PDA

View Full Version : Red DRAGON Not seeing Lens data on Canon. Other issues



Chris Jordan
09-12-2014, 08:09 PM
Hey guys, we tried to go shoot with our Dragon for the first time today, and the lens was stuck wide open, as well as the touch screen worked 50% of the time. VERY frustrating when you have a ton of people waiting on you and lots of $$$ going out the window. We ended up just going back to the Epic for the shoot. Any ideas?! Current firmware.

Mike P.
09-12-2014, 08:52 PM
Did you try a different lens?

Reseat, reload firmware, reconnect touch? Try everything on the other camera and make sure it's solid?

Phil Holland
09-13-2014, 02:34 AM
Which lens? Also need a bit more info on the LCD Touch issues. Mike's recommendations are solid. Just curious to what is going on and what you're experiencing.

Owen Rennie
09-13-2014, 04:10 AM
I had the same thing happen today once I connected a x2 extender to the canon 70-200 2.8

A quick twist lens off and on again and the aperture showed back up on the Monitor...