I feel like the previous firmware was much more stable about this. I still get this error in 2k/4k on 7.0.0