Thread: Side handle not working

Reply to Thread
Results 1 to 9 of 9
  1. #1 Side handle not working 
    Hey guys, I've seen some similar problems with side handles mentioned in the forums but nothing quite matches exactly.

    I have an Epic Dragon which came with a side handle (which works fine) but I bought a second hand DSMC Side handle and when I connected it to the camera it got stuck in a loop of upgrading the firmware and needing to shut down. After battling this for a while I decided to try updating the firmware to the newest (6.3.47) to see if that helped. After updating the firmware I no longer get a message saying it has to upgrade the side handle firmware, instead it boots up normally but the battery in the side handle shows up as "UNKWN" and the handle doesn't do anything - knobs and buttons are completely dead.

    I bought this side handle for a second unit - a non Dragon Epic which is out on rental until tomorrow so I'll try and see what happens when I connect to that but I figured I'd see if anyone had any ideas.

    I've tried going to 'rediscover' and unseating everything and disconnecting power and all that.

    Any ideas would be welcomed!
    Reply With Quote  
     

  2. #2  
    Update:

    I've now tried to use the side handle on both an Epic Dragon and Epic-MX (each upgraded to newest firmware and then I rolled them back to v6.0.46 as per RED tech support's suggestion) and I'm still having no luck with this handle. As mentioned before I have a second side handle that works just fine on both cameras.



    I bought this thing on eBay - should I assume it is a dud and send it back? or is there anything else I could try? Any help would be appreciated!
    Reply With Quote  
     

  3. #3  
    Senior Member James Drake's Avatar
    Join Date
    Oct 2009
    Location
    Denver
    Posts
    437
    Long time since this was posted but did you find a solution Chris? Iím in the exact same situation you were in
    Epic-M #1169
    Visit us at www.jdfnet.com
    Reply With Quote  
     

  4. #4  
    Encountered this one a while back and the side handle had to be sent to RED to get its firmware updated. You may be able to get it’s firmware updated properly by juggling camera firmware versions, but the cameras can only roll back so far. It’s like if the side handle has firmware that’s too far out of date the camera doesn’t know how to properly address it and upgrade it.

    James, I also have an EPIC/ DSMC side handle here if you need another to try. It may be interesting to see as it’s been in its case and on the shelf for over a year. Keep meaning to sell it and all that... Don’t have a camera that uses it anymore.
    - Jeff Kilgroe
    - Applied Visual Technologies, LLC | RojoMojo
    - Just me and my 8K Monstro VV kicking ass.
    Reply With Quote  
     

  5. #5  
    Senior Member
    Join Date
    Apr 2007
    Location
    Belgium, Antwerp/Ostend
    Posts
    1,082
    I have 2x side handles with scroll wheel not working anymore after updating and rolling back and forth between updates.
    camera operator/ editing / sound / DIT
    specular.productions@gmail.com
    Reply With Quote  
     

  6. #6  
    Senior Member James Drake's Avatar
    Join Date
    Oct 2009
    Location
    Denver
    Posts
    437
    Thanks for the reply Jeff! Long time no see, hope you are well!

    I believe you're right on. My current side handle with missing button works fine...but it's been updated along the way. I bet this one I bought is an early version of firmware and it just doesn't know how to get past it. I sent my log file to Red and I'm just ever so hoping they can identify some issue that lets me fix it at home, they indicated that they don't service the DSMC1 side handles anymore so we'll see how it all pans out!

    I'll post back when I find out next steps!

    Quote Originally Posted by Jeff Kilgroe View Post
    Encountered this one a while back and the side handle had to be sent to RED to get its firmware updated. You may be able to get itís firmware updated properly by juggling camera firmware versions, but the cameras can only roll back so far. Itís like if the side handle has firmware thatís too far out of date the camera doesnít know how to properly address it and upgrade it.

    James, I also have an EPIC/ DSMC side handle here if you need another to try. It may be interesting to see as itís been in its case and on the shelf for over a year. Keep meaning to sell it and all that... Donít have a camera that uses it anymore.
    Epic-M #1169
    Visit us at www.jdfnet.com
    Reply With Quote  
     

  7. #7  
    Senior Member James Drake's Avatar
    Join Date
    Oct 2009
    Location
    Denver
    Posts
    437
    Sorry to hear that Sven, did you send a log file to Red support?

    Quote Originally Posted by Sven Seynaeve View Post
    I have 2x side handles with scroll wheel not working anymore after updating and rolling back and forth between updates.
    Epic-M #1169
    Visit us at www.jdfnet.com
    Reply With Quote  
     

  8. #8  
    Senior Member Antony Newman's Avatar
    Join Date
    Mar 2012
    Location
    London, UK.
    Posts
    1,546
    1) Check to see the firmware version is actually the latest for the SH.
    -> if not, take everything off the camera with the exception of the SH.
    This will increase the chance the SH will advertise its existence to the brain during startup (on the I^2 bus).

    2) If on latest F/W - try another SH on your brain, and your SH on another brain (this will help localise the fault).

    3) (carefully) Remove any dust/dirt from contacts of SH

    4) If all else fails - using a small amount of isopropyl alcohol to clean all the contacts with an cotton bud (earbud).

    AJ
    Reply With Quote  
     

  9. #9  
    Senior Member James Drake's Avatar
    Join Date
    Oct 2009
    Location
    Denver
    Posts
    437
    Thank you for that advice!

    After trying many of those steps and the upgrade/downgrade firmware cycle, the Red support team is suggesting I send it in because as Jeff suggested, the firmware mismatch is probably to great to upgrade the side handle at this point. Just not sure how $ it will be to send the side handle in

    Quote Originally Posted by Antony Newman View Post
    1) Check to see the firmware version is actually the latest for the SH.
    -> if not, take everything off the camera with the exception of the SH.
    This will increase the chance the SH will advertise its existence to the brain during startup (on the I^2 bus).

    2) If on latest F/W - try another SH on your brain, and your SH on another brain (this will help localise the fault).

    3) (carefully) Remove any dust/dirt from contacts of SH

    4) If all else fails - using a small amount of isopropyl alcohol to clean all the contacts with an cotton bud (earbud).

    AJ
    Epic-M #1169
    Visit us at www.jdfnet.com
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts