Thread: Problem Getting REDMOTE to Charge - HELP

Reply to Thread
Results 1 to 7 of 7
  1. #1 Problem Getting REDMOTE to Charge - HELP 
    I'm a first-time RED owner, and whilst prepping for my first shoot today I realized that my REDMOTE is dead, though the original owner had mentioned he hardly ever used it during his ownership and couldn't comment on its functionality as it had been so long so I'm not surprised that it didn't have a charge. I had learnt that there are two methods to charge the device either via the Mini USB port located on the side of the REDMOTE, or by docking it to the back of the brain and turning it on as well; both turn on the REDMOTE and it seems to operate normally, and want to immediatley search for the brain, however it does not want to charge. I had considered maybe just poweing off the device by holidng down the sliding toggle switch until promped with some options, though every time I select the option to shut down the REDMOTE it boots back up shortly after beiung shut down. My next course of action was to hold the on/off slider down until the device forces a shutdown and hoping it will charge without booting up and to no surprise it does not charge when powered off. I tried both these methods using both charging options and I cannot seem to get the remote to hold a charge even when giving it a bit to charge whilst powered on, it remains on the lowest portion of the battery status indicator.

    Has anybody else dealt with this? The device appears to be in mint condition and when it's on, it seems to work, but I worry the actual battery inside may need to be replaced so I'm debating contacting RED tomorrow about this situation.

    I also understand that there may be the possibility that I may be going about charging it wrong or overlooking another method, but I've tried all I could. Any thoughts/suggestions are much appreciated, thanks.
    Reply With Quote  

  2. #2  
    Senior Member Terry VerHaar's Avatar
    Join Date
    Sep 2009
    Marin County, CA
    I have always found that the easiest way to charge it is to hook it up to a power source via USB cable. I do seem to recall that the unit has to be on to charge. That always worked for me. If your unit is not charging (it can take awhile), it is possible that the internal battery may need replacement. Can't hurt to contact RED but plan on at least a couple hundred dollar repair cost.

    Good luck!
    Scarlet Dragon #01474, "ISABELLA"
    Scarlet-W in transit!!
    Reply With Quote  

  3. #3  
    Senior Member Bob Gundu's Avatar
    Join Date
    Mar 2011
    Toronto, ON Canada
    It takes forever to charge it. Leave it overnight while it’s on to charge.

    VFX, Cinematographer, Photographer
    10 frame handles
    Reply With Quote  

  4. #4  
    Thanks, I'll try charging it longer and see if that makes any difference.
    I'll post updates on the results.
    Reply With Quote  

  5. #5  

    It appears that no amount of charging time for the REDMOTE has managed to give the battery any ability to power on once unplugged. The battery status indicator at the bottom right of the screen has remained at it's the lowest status and I conclude that I may need to call RED regarding a dead/defective Li-ion bat for service. Kinda sucks, just bought this with my package not too long ago and never got to use it, I imagine it would have come in handy on many instances. Thank you to those who gave suggestions to be paitent, unfortuatley no amount of patience will make this device usable when it's not recieving direct power from an external source.
    Reply With Quote  

  6. #6  
    Join Date
    May 2017
    Chicago, IL
    I've faced alot of similar issues with used REDMOTES that I've worked with - the internal battery on those is lousy to say the least. Best of luck moving forward!
    Reply With Quote  

  7. #7  
    Senior Member Alex Lubensky's Avatar
    Join Date
    Nov 2016
    Kiev, Ukraine
    It's a known issue. Just power it from a portable source (ie power bank). Internal batteries are a pain in Red ecosystem.
    Reply With Quote  

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts