Thread: Red Epic Dragon starts powering on then goes to yellow light...

Reply to Thread
Results 1 to 3 of 3
  1. #1 Red Epic Dragon starts powering on then goes to yellow light... 
    Senior Member Ryan Sheets's Avatar
    Join Date
    Mar 2015
    Location
    Jackson, Wy
    Posts
    233
    After years of use and perfect starts, my Red Epic Dragon wouldn't turn on today. Fans start up and camera has power...only gets stuck on yellow light. (Won't go green)

    Tried different batteries, different power cords, etc...and was able to get it to start up after a few hours. Then it stopped again and only went to yellow. Nothing different or out of the ordinary. Anyone seen this before?

    Thanks,

    Ryan
    Reply With Quote  
     

  2. #2  
    Senior Member
    Join Date
    Dec 2010
    Location
    Toronto & Vancouver
    Posts
    3,462
    Hey Ryan, have you tried detaching all the modules (including SSD and even mount) and powering via AC... You won't have monitor (without the SSDmodule), but you should be able to tell if you have more consistent green-light vs. yellow-light boot ups.

    Has it done any travel/rental/massive temp changes recently?
    Reply With Quote  
     

  3. #3  
    Senior Member
    Join Date
    Dec 2010
    Location
    Toronto & Vancouver
    Posts
    3,462
    Ryan, what ended up happening with this?
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts