Click here to go to the first RED TEAM post in this thread.   Thread: RedVolt Quad Charger...

Reply to Thread
Results 1 to 2 of 2
  1. #1 RedVolt Quad Charger... 
    Senior Member Eric Oh's Avatar
    Join Date
    Nov 2012
    Location
    Barcelona/Toronto
    Posts
    206
    I'm not sure if its my REDVOLT XLs or its the Quad charger. I hardly use both but was looking at setting up a very lightweight build so I decided to dust off the XLs. Stuck them in to charge and for the first minute of so the LEDs flash yellow (battery on, and charging). After a minute of so the LEDs Strat flashing the dreaded red and green (fault).

    I thought maybe I need to drain my REDvolts to cycle them so I used one until there was 3% left. Stuck in on the charger and the same thing. I'd hate to think my RedVolts are shot (all 4 of them) as I've probably only put around 10 cycles on them. I've read that the Quad Chargers are prone to this. Tried un-mounting then re-mounting the batteries, unplugging the charger, and all the same result with all 4 of my REDVolts. Thoughts / suggestions anyone? Looks I best stick to my AB batteries....
    Eric Oh, CSC
    Cinematographer

    www.vimeopro.com/ericoh/dop
    www.instagram.com/ericoh_csc

    Monstro | Sigma Cine Primes | GL Optics 70-200mm | Clavius Lenses | RT Motion Latitude
    Reply With Quote  
     

  2.   This is the last RED TEAM post in this thread.   #2  
    SWAT Brent@RED's Avatar
    Join Date
    Aug 2007
    Location
    Irvine CA
    Posts
    4,924
    Eric, please file a support ticket if you have not already done so.
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts