Click here to go to the first RED TEAM post in this thread.   Thread: RED Epic MX not updating firmware

Reply to Thread
Results 1 to 5 of 5
  1. #1 RED Epic MX not updating firmware 
    Any have experience with firmware updates not sticking on the Epic? Have tried every recent version since 2016 nothing will stick on the camera still on version 4.
    Reply With Quote  
     

  2. #2  
    Hey Tyler,

    You will need to download version 5.3.49 first then you will be able to install the current release.
    Reply With Quote  
     

  3. #3  
    Sadly, that's the first thing I tried. I have gone as far as it running through the update process (blinking lights, fan kick, etc.) all correctly. All signs of a successful update, except when I look in the menus it is still on the version 4. Very weird, was hoping someone has experienced this as well.
    Reply With Quote  
     

  4. #4  
    No one else has had this problem?
    Reply With Quote  
     

  5.   This is the last RED TEAM post in this thread.   #5  
    RED TEAM Brad Harris's Avatar
    Join Date
    Nov 2010
    Location
    RED HQ - Irvine, CA
    Posts
    48
    Hi Tyler,

    I see that you've been in contact with the RED Product Support Team. If you can please respond to the support ticket with the requested information, we can continue to look into this for you.
    Reply With Quote  
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts